Moose on SL5

March 3, 2008

I’ve been working through packaging the Moose perl module and its dependencies for SL5. This has now been done and you can now use an LCFG header (currently “develop” only) to include the packages like this:

#include <lcfg/options/perl-moose.h>

I will add the modules for FC6 in next. All the packages which weren’t provided in epel have been built locally and put into the new “world” bucket.

To get the new release tools on the SL5 machine as well you will need this:

!profile.packages    mEXTRA(perl-Data-Structure-Util-0.12-1.inf \
                                              perl-YAML-Syck-0.98-1.el5\
                                              perl-UNIVERSAL-require-0.11-1.el5/noarch\
                                              perl-LCFG-Build-PkgSpec-0.0.5-1/noarch\
                                              perl-LCFG-Build-VCS-0.0.5-1/noarch)